Trouble with spillmatrix RMD script

Looking for ways to analyze your dataset? Need help with a software package?
Computational image analysis of multiplexed Imaging Mass Cytometry acquisitions
Post Reply
asasama12
Posts: 2
Joined: Fri Oct 04, 2019 6:28 pm

Trouble with spillmatrix RMD script

Post by asasama12 » Thu Oct 08, 2020 7:41 pm

Hello,
I am attempting to calculate a spillover matrix following the protocol from Chevrier et.al., 2018, using this R markdown script (https://github.com/BodenmillerGroup/cyT ... at_long.md) but I'm having trouble getting the actual spillover matrix to calculate.
From line 125:

Code: Select all

```{r Binned}
res = lapply(dats_agg, function(x) re_from_dat(x,
                                               ss_ms=x[!is.na(mass), unique(mass)],
                                               minevents = 40,
                                              correct_bc = T))
sms = lapply(res, function(x) computeSpillmat(x))

Error in CATALYST::assignPrelim(x = ff, y = ss_ms) : unused argument (y = ss_ms)
4.
re_from_dat(x, ss_ms = x[!is.na(mass), unique(mass)], minevents = 40, correct_bc = T)
3.
FUN(X[[i]], ...)
2.
lapply(dats_agg, function(x) re_from_dat(x, ss_ms = x[!is.na(mass), unique(mass)], minevents = 40, correct_bc = T))
1.
lapply(dats_agg, function(x) re_from_dat(x, ss_ms = x[!is.na(mass), unique(mass)], minevents = 40, correct_bc = T))


```
Does anyone have any experience or insight into why this error is occurring? I believe I have formatted the input files correctly and the visualizations of median intensities have worked successfully before this point.
Post Reply